読者です 読者をやめる 読者になる 読者になる

JL1NIE ’s blog

趣味のアマチュア無線やプログラミングについて徒然と。

WSJT-X on Raspberry Pi

 Raspberry Pi + 液晶タッチディスプレイで移動用JT9端末環境の構築が出来ないか実験中です。そもそもマシンパワーがギリギリな気がするので、色々散財する前に、これをクリアできないか確認中。うまくいけばCAT controlを改造してi2cバス経由でVFOを制御、件の

JT65 / PSK / BPSK QRP TRANSCEIVER

と一体化できないかと妄想しています。

f:id:CentralAttack:20160206100729j:plain

手始めに普段weather stationとして使っているRaspberry Pi に開発バージョンのWSJT-Xのインストールの作業を始めました。1.7.0から軟判定RSデコーダのバイナリパッケージが不要になったそうです。以前からお願いすれば通常のdistributionにないバイナリパッケージも送付いただけたようですが、こちらの方が気が楽ですね。早速、リリースノートにしたがってこちらを実行してみました。

  • sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 862549F9
  • sudo nano /etc/apt/sources.list
  • Add the following to the end of sources.list

# -----
deb http://ppa.launchpad.net/ki7mt/wsjtx-next/ubuntu trusty main
# -----

  • Ctrl+X to save and exit
  • sudo apt-get update
  • sudo apt-get install wsjtx

すると、

wsjtx : Depends: libfftw3-double3 but it is not installable
Depends: libfftw3-single3 but it is not installable
Depends: libqt5core5a (>= 5.2.0) but it is not installable
Depends: libqt5gui5 (>= 5.0.2) but it is not installable or
libqt5gui5-gles (>= 5.0.2) but it is not installable
Depends: libqt5multimedia5 (>= 5.2.0) but it is not installable
Depends: libqt5network5 (>= 5.0.2) but it is not installable
Depends: libqt5serialport5 (>= 5.1.0) but it is not installable
Depends: libqt5widgets5 (>= 5.2.0) but it is not installable
Depends: libqt5multimedia5-plugins but it is not installable
Depends: libqt5multimediawidgets5 but it is not installable
Depends: libqt5opengl5 but it is not installable

headless運用でしたので必要なライブラリがたくさん。まだまだ道は遠いですね。